Tutorials

Which OS for which Mac? A list of compatibilities

December 2019

Here is a simple list of compatibilities to help you see which OS is supported by your Mac.

MacOS Catalina (10.15)

  • MacBook (2015 or more recent)
  • MacBook Air (mid-2012 or more recent)
  • MacBook Pro (mid-2012 or more recent)
  • Mac mini (2012 or more recent)
  • iMac (end of 2012 or more recent)
  • iMac Pro (2017)
  • Mac Pro (2013)

MacOS Mojave (10.14)

  • MacBook (2015 or more recent)
  • MacBook Air (mid-2012 or more recent)
  • MacBook Pro (mid-2012 or more recent)
  • Mac mini (mid-2012 or more recent)
  • iMac (end of 2012 or more recent)
  • iMac Pro (2017)
  • Mac Pro (end of 2013)

MacOS High Sierra (10.13)

MacBook and iMac from the beginning of 2009 minimum.

All MacBook Air, MacBook Pro, Mac mini and Mac from 2010.

MacOS Sierra (10.12)

  • MacBook (end of 2009 or more recent)
  • MacBook Pro (mid-2010 or more recent)
  • MacBook Air (end of 2010 or more recent)
  • Mac mini (mid-2010 or more recent)
  • iMac (end of 2009 or more recent)
  • Mac Pro (mid-2010 or more recent)

 

OS X El Capitan (10.11)

  • MacBook (2015)
  • MacBook (2009 or more recent)
  • MacBook Pro (mid/end of 2007 or more recent)
  • MacBook Air (end of 2008 or more recent)
  • Mac mini (2009 or more recent)
  • iMac (mid-2007 or more recent)
  • Mac Pro (2008 or more recent)
  • Xserve (2009)

OS X Yosemite (10.10)

  • iMac (mid-2007 or more recent)
  • MacBook (debut 2009 or more recent)
  • MacBook Pro (13″, mid-2009 or more recent), (15″, mid/end of 2007 or more recent), (17″, end of 2007 or more recent)
  • MacBook Air (end of 2008 or more recent)
  • Mac Mini (2009 or more recent)
  • Mac Pro (2008 or more recent)
  • Xserve (2009)

OS X Mavericks (10.9)

  • iMac (mid-2007 or more recent)
  • MacBook (13″ Aluminium, end of 2008), (13″, 2009 or more recent)
  • MacBook Pro (13″, mid-2009 or more recent), (15″, mid/end of 2007 or more recent), (17″, end of 2007 or more recent)
  • MacBook Air (end of 2008 or more recent)
  • Mac Mini (2009 or more recent)
  • Mac Pro (2008 or more recent)
  • Xserve (2009)

OS X Mountain Lion (10.8)

  • iMac (mid-2007 or more recent)
  • MacBook (2008 in aluminium, 2009 or more recent)
  • MacBook Pro (mid/end of 2007 or more recent)
  • Xserve (2009)
  • MacBook Air (end of 2008 or more recent)
  • Mac mini (2009 or more recent)
  • Mac Pro (2008 or more recent)

Share

Leave your comments here :)

Don't hesitate to leave a review!